summaryrefslogtreecommitdiff
path: root/mathematica.patch
diff options
context:
space:
mode:
Diffstat (limited to 'mathematica.patch')
-rw-r--r--mathematica.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/mathematica.patch b/mathematica.patch
new file mode 100644
index 0000000..159512c
--- /dev/null
+++ b/mathematica.patch
@@ -0,0 +1,20 @@
+--- a/opt/Wolfram/WolframEngine/12.0/Executables/mathematica 2019-06-24 18:28:09.000000000 -0400
++++ b/opt/Wolfram/WolframEngine/12.0/Executables/mathematica 2019-11-18 23:51:47.611627563 -0500
+@@ -18,6 +18,8 @@
+ SystemIDList="Linux-x86-64 Linux";;
+ armv?l)
+ SystemIDList="Linux-ARM";;
++ aarch64)
++ SystemIDList="Linux-ARM";;
+ *)
+ SystemIDList="Unknown";;
+ esac;;
+@@ -73,7 +75,7 @@
+ export LD_LIBRARY_PATH="${M_LIBRARY_PATH}/Qt/lib/${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}"
+ fi
+
+-export LD_LIBRARY_PATH="${M_LIBRARY_PATH}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}"
++export LD_LIBRARY_PATH="/usr/libv6h:${M_LIBRARY_PATH}${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}"
+ export PATH="${ExecutablesDirectory}:${PATH}"
+
+ #set LIBGL flag on Linux-ARM version to prevent crash on startup