summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2017-07-07 14:40:39 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2017-07-07 14:40:39 -0400
commit0492bba1c50c1da1a9048f1212cd933674e48b2a (patch)
tree627889cf550132b0f37e1daa96d6b19c5c6f6dad /CMakeLists.txt
parent9cc92bd630302936bbd7a41ac48de16678b615a3 (diff)
parent701cde10f6a43a4d0c3409e1a9bde74040baee22 (diff)
downloadfuse_networks-0492bba1c50c1da1a9048f1212cd933674e48b2a.tar.gz
fuse_networks-0492bba1c50c1da1a9048f1212cd933674e48b2a.tar.bz2
fuse_networks-0492bba1c50c1da1a9048f1212cd933674e48b2a.zip
Merge branch 'master' of wopr:doc/research/sethna/code/fracture
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3cb6aeb..ade950f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,8 +1,8 @@
-cmake_minimum_required(VERSION 3.7)
+cmake_minimum_required(VERSION 3.5)
project(fracture)
-include_directories(src ~/.local/include)
+include_directories(src ~/.local/include /usr/include/suitesparse)
link_directories(~/.local/lib)
file(GLOB LIB_SOURCES lib/*.c)
@@ -15,5 +15,6 @@ foreach( src_file ${EXE_SOURCES} )
string( REGEX REPLACE ".*/src/(.*)\.c" "\\1" exe_name ${src_file} )
add_executable( ${exe_name} ${src_file} )
target_link_libraries(${exe_name} fracture_stuff gsl c cblas lapack dl pthread cholmod amd colamd suitesparseconfig camd ccolamd rt metis m jst tcmalloc profiler)
+ install(TARGETS ${exe_name} DESTINATION bin)
endforeach( src_file ${EXE_SOURCES} )