summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2023-11-23 12:05:32 +0100
committerJaron Kent-Dobias <jaron@kent-dobias.com>2023-11-23 12:05:32 +0100
commitf363ff276577d5fea4e2ac10b65c52be8c1e7445 (patch)
tree50b114ca53d462a497e8cff2a97a4405c1fcc450
parent7c2294ef88bcc16073d2eaf5f7528ad89c1ee8bb (diff)
downloadlinux-raspberrypi4-f363ff276577d5fea4e2ac10b65c52be8c1e7445.tar.gz
linux-raspberrypi4-f363ff276577d5fea4e2ac10b65c52be8c1e7445.tar.bz2
linux-raspberrypi4-f363ff276577d5fea4e2ac10b65c52be8c1e7445.zip
Updated PKGBUILD and version.
-rw-r--r--PKGBUILD49
1 files changed, 26 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2211a2..7264d87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,20 @@
# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgbase=linux-raspberrypi4
-pkgver=6.6.1.rpi1
+pkgver=6.6.2.rpi2
pkgrel=1
-pkgdesc='Pinebook Pro Linux'
-_srctag=v${pkgver%.*}-${pkgver##*.}
-url="https://git.kent-dobias.com/system/linux/log/?h=$_srctag"
+pkgdesc='Raspberry Pi Linux'
+url='https://git.kent-dobias.com/system/linux'
arch=(aarch64)
license=(GPL2)
makedepends=(
bc
cpio
gettext
- git
libelf
pahole
perl
+ python
tar
xz
@@ -27,29 +26,34 @@ makedepends=(
lld
)
options=('!strip')
-_srcname=kentdobias-linux
+_srcname=linux-${pkgver%.*}
+_srctag=v${pkgver%.*}-${pkgver##*.}
source=(
- "$_srcname::git+https://git.kent-dobias.com/system/linux?signed#tag=$_srctag"
+ https://cdn.kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/${_srcname}.tar.{xz,sign}
+ "linux-$_srctag.patch::$url/rawdiff/?id=$_srctag&id2=v${pkgver%.*}"
config # the main kernel config file
)
validpgpkeys=(
ABAF11C65A2970B130ABE3C479BE3E4300411886 # Linus Torvalds
647F28654894E3BD457199BE38DBBDC86092693E # Greg Kroah-Hartman
A2FF3A36AAA56654109064AB19802F8B0D70FC30 # Jan Alexander Steffens (heftig)
- C7E7849466FE2358343588377258734B41C31549 # David Runge <dvzrv@archlinux.org>
0E3A444DD0760E65901BF59679E824090BD31086 # Jaron Kent-Dobias
)
-b2sums=('SKIP'
+# https://www.kernel.org/pub/linux/kernel/v6.x/sha256sums.asc
+sha256sums=('73d4f6ad8dd6ac2a41ed52c2928898b7c3f2519ed5dbdb11920209a36999b77e'
+ 'SKIP'
+ 'e22eefd7876c68255ded8893ed9d93d98fcffdc6c1c9b054afa65affd6742068'
+ '9b14d545bfda8464701548ccfdecf2f1c301469e6eead5d0733817dc9f48b4ed')
+b2sums=('88fc55107834d4308d33547211a031674ffaa8e48e23d6612ba39430292b18073d49271bd3ce8c7be01d8c5668482cb1715071abfd9b1f75b06468a09f8f4eec'
+ 'SKIP'
+ '356d4e516367867798f00e8ff2130482ea3f35ad98eb53c05dac3f60201ac4fa22d4e435d70d844d93d15d64174b7cbd14a975f9e93c6b420bf82bfdbeb7d3a6'
'ef7d78daeb9c2658392e8a0050ef5fdb85dd14c8bc94c26914d9580c344127e29371ab0166ca44e958b6b073dc2e34ec232db9678831c5173baa6b829846e5a7')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
-
-_make() {
- test -s version
- make ARCH=arm64 LLVM=1 KERNELRELEASE="$(<version)" "$@"
-}
+export ARCH=arm64
+export LLVM=1
prepare() {
cd $_srcname
@@ -57,14 +61,12 @@ prepare() {
echo "Setting version..."
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
- make ARCH=arm64 LLVM=1 defconfig
- make ARCH=arm64 LLVM=1 -s kernelrelease > version
- _make mrproper
local src
for src in "${source[@]}"; do
src="${src%%::*}"
src="${src##*/}"
+ src="${src%.zst}"
[[ $src = *.patch ]] || continue
echo "Applying patch $src..."
patch -Np1 < "../$src"
@@ -72,16 +74,17 @@ prepare() {
echo "Setting config..."
cp ../config .config
- _make olddefconfig
+ make olddefconfig
diff -u ../config .config || :
+ make -s kernelrelease > version
echo "Prepared $pkgbase version $(<version)"
}
build() {
cd $_srcname
- _make all
-# $_make htmldocs
+ make all
+# make htmldocs
}
_package() {
@@ -113,17 +116,17 @@ _package() {
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- install -Dm644 "$(_make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
# Used by mkinitcpio to name the kernel
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- _make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ ZSTD_CLEVEL=19 make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
DEPMOD=/doesnt/exist modules_install # Suppress depmod
echo "Installing dtbs..."
- _make INSTALL_DTBS_PATH="${pkgdir}/boot/dtbs" dtbs_install
+ make INSTALL_DTBS_PATH="${pkgdir}/boot/dtbs" dtbs_install
find "${pkgdir}/boot/dtbs/broadcom" -type f -print0 | xargs -0 mv -t "${pkgdir}/boot"
# remove build link