summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2023-10-12 16:32:09 +0200
committerJaron Kent-Dobias <jaron@kent-dobias.com>2023-10-12 16:32:09 +0200
commit5e4655030fb969ef39a7849922f82a9f62cd9cf9 (patch)
tree8a2eac786f971e94ac762c1aba3963e99a279ddd /PKGBUILD
parentd5279a369578c81212463e4e8eff1b4f40a73f16 (diff)
downloadlinux-raspberrypi4-5e4655030fb969ef39a7849922f82a9f62cd9cf9.tar.gz
linux-raspberrypi4-5e4655030fb969ef39a7849922f82a9f62cd9cf9.tar.bz2
linux-raspberrypi4-5e4655030fb969ef39a7849922f82a9f62cd9cf9.zip
Updated to v6.5.7-rpi1.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD87
1 files changed, 58 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80efdc3..7b4a4d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,65 @@
# Maintainer: Jaron Kent-Dobias <jaron@kent-dobias.com>
+# Contributor: Vasily Khoruzhick <anarsoul@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgbase=linux-raspberrypi4
-pkgver=6.1.9.rpi1
+pkgver=6.5.7.rpi1
pkgrel=1
-pkgdesc='Raspberry Pi 4 Linux'
+pkgdesc='Pinebook Pro Linux'
_srctag=v${pkgver%.*}-${pkgver##*.}
url="https://git.kent-dobias.com/system/linux/log/?h=$_srctag"
arch=(aarch64)
license=(GPL2)
makedepends=(
- bc kmod libelf pahole
+ bc
+ cpio
+ gettext
git
+ libelf
+ pahole
+ perl
+ tar
+ xz
+
dtc
- clang llvm lld
+ clang
+ llvm
+ lld
)
options=('!strip')
_srcname=kentdobias-linux
source=(
"$_srcname::git+https://git.kent-dobias.com/system/linux?signed#tag=$_srctag"
- config
+ config # the main kernel config file
)
validpgpkeys=(
- 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
- '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
- '8218F88849AAC522E94CF470A5E9288C4FA415FA' # Jan Alexander Steffens (heftig)
- '0E3A444DD0760E65901BF59679E824090BD31086' # Jaron Kent-Dobias
+ ABAF11C65A2970B130ABE3C479BE3E4300411886 # Linus Torvalds
+ 647F28654894E3BD457199BE38DBBDC86092693E # Greg Kroah-Hartman
+ A2FF3A36AAA56654109064AB19802F8B0D70FC30 # Jan Alexander Steffens (heftig)
+ C7E7849466FE2358343588377258734B41C31549 # David Runge <dvzrv@archlinux.org>
+ 0E3A444DD0760E65901BF59679E824090BD31086 # Jaron Kent-Dobias
)
-sha256sums=('SKIP'
- '99a540ed7a70c58885f85d8d70c7c69b5fbf21fca9c532422e150e20641a06a6')
+b2sums=('SKIP'
+ '02e5a7690e1257de0dc53148e2060a56058b5dd77a9c64094c5ea9686fa5ea39c66c169e2073b888869229d514e253c9e5389904113bf78816871dfd6464ea84')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EPOCH})"
-_make='make ARCH=arm64 LLVM=1'
+_make() {
+ test -s version
+ make ARCH=arm64 LLVM=1 KERNELRELEASE="$(<version)" "$@"
+}
prepare() {
cd $_srcname
echo "Setting version..."
- scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
+ make ARCH=arm64 LLVM=1 defconfig
+ make ARCH=arm64 LLVM=1 -s kernelrelease > version
+# make mrproper
local src
for src in "${source[@]}"; do
@@ -54,48 +72,59 @@ prepare() {
echo "Setting config..."
cp ../config .config
- $_make olddefconfig
+ _make olddefconfig
+ diff -u ../config .config || :
- $_make -s kernelrelease > version
echo "Prepared $pkgbase version $(<version)"
}
build() {
cd $_srcname
- $_make all
+ _make all
# $_make htmldocs
}
_package() {
pkgdesc="The $pkgdesc kernel and modules"
- depends=(coreutils kmod initramfs)
- optdepends=('crda: to set the correct wireless channels of your country'
- 'linux-firmware: firmware images needed for some devices')
- provides=(linux=$pkgver VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
- replaces=(virtualbox-guest-modules-arch wireguard-arch)
- conflicts=(linux)
+ depends=(
+ coreutils
+ initramfs
+ kmod
+ )
+ optdepends=(
+ 'wireless-regdb: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices'
+ )
+ provides=(
+ KSMBD-MODULE
+ VIRTUALBOX-GUEST-MODULES
+ WIREGUARD-MODULE
+ )
+ replaces=(
+ virtualbox-guest-modules-arch
+ wireguard-arch
+ )
cd $_srcname
- local kernver="$(<version)"
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+ local modulesdir="$pkgdir/usr/lib/modules/$(<version)"
echo "Installing boot image..."
install -Dm644 arch/arm64/boot/Image "${pkgdir}/boot/kernel8.img"
-# install -Dm644 arch/arm64/boot/Image.gz "${pkgdir}/boot/Image.gz"
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- install -Dm644 "$($_make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$(_make -s image_name)" "$modulesdir/vmlinuz"
# Used by mkinitcpio to name the kernel
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- $_make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
+ _make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ DEPMOD=/doesnt/exist modules_install # Suppress depmod
echo "Installing dtbs..."
- $_make INSTALL_DTBS_PATH="${pkgdir}/boot" dtbs_install
- find "${pkgdir}/boot/broadcom" -type f -print0 | xargs -0 mv -t "${pkgdir}/boot"
+ _make INSTALL_DTBS_PATH="${pkgdir}/boot/dtbs" dtbs_install
+ find "${pkgdir}/boot/dtbs/broadcom" -type f -print0 | xargs -0 mv -t "${pkgdir}/boot"
# remove build and source links
rm "$modulesdir"/{source,build}