summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2019-09-23 11:14:50 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2019-09-23 11:14:50 -0400
commita16864d468d58576f0525b58007b96f5d045d945 (patch)
treeed44a76a8154cd7fa4d41c25f156667a92e3affc /CMakeLists.txt
parente817d415f02bae04881a5f0d3c1f1e313a892014 (diff)
downloadfuse_networks-a16864d468d58576f0525b58007b96f5d045d945.tar.gz
fuse_networks-a16864d468d58576f0525b58007b96f5d045d945.tar.bz2
fuse_networks-a16864d468d58576f0525b58007b96f5d045d945.zip
added a symlink to build dir compile_commands.json, and gave the cake project a name
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e3f70d8..f5b6d1a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,8 @@
cmake_minimum_required(VERSION 3.8)
+project(fracture)
+
set(CMAKE_CXX_FLAGS_DEBUG "-g -Wall")
set(CMAKE_CXX_FLAGS_RELEASE "-O3 -flto -Wall -march=native")