summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2017-06-22 16:46:36 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2017-06-22 16:46:36 -0400
commita1e4be2ad8e2f2354e6f36bce293e0f07e3c5f2f (patch)
tree31a560f3dc29829b064ae413582a6ef6a3e44a49 /CMakeLists.txt
parent23682e445ba64452c453346f516f9101761438ba (diff)
downloadfuse_networks-a1e4be2ad8e2f2354e6f36bce293e0f07e3c5f2f.tar.gz
fuse_networks-a1e4be2ad8e2f2354e6f36bce293e0f07e3c5f2f.tar.bz2
fuse_networks-a1e4be2ad8e2f2354e6f36bce293e0f07e3c5f2f.zip
updated cmake file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3cb6aeb..1e0a7f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
-cmake_minimum_required(VERSION 3.7)
+cmake_minimum_required(VERSION 3.5)
project(fracture)
include_directories(src ~/.local/include)
@@ -15,5 +15,6 @@ foreach( src_file ${EXE_SOURCES} )
string( REGEX REPLACE ".*/src/(.*)\.c" "\\1" exe_name ${src_file} )
add_executable( ${exe_name} ${src_file} )
target_link_libraries(${exe_name} fracture_stuff gsl c cblas lapack dl pthread cholmod amd colamd suitesparseconfig camd ccolamd rt metis m jst tcmalloc profiler)
+ install(TARGETS ${exe_name} DESTINATION bin)
endforeach( src_file ${EXE_SOURCES} )