summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2019-10-02 10:46:17 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2019-10-02 10:46:17 -0400
commit47a7c96d1848e3a3edbcfb17e645790d31c01a67 (patch)
treee45bf1cc6c57338cdd064acf0aa8e7a210d306fb /src/CMakeLists.txt
parent172d281943371a3aaa04a1a4d564731178e782e7 (diff)
downloadfuse_networks-47a7c96d1848e3a3edbcfb17e645790d31c01a67.tar.gz
fuse_networks-47a7c96d1848e3a3edbcfb17e645790d31c01a67.tar.bz2
fuse_networks-47a7c96d1848e3a3edbcfb17e645790d31c01a67.zip
cleaned up libraries and reduced number of binaries
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt15
1 files changed, 3 insertions, 12 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9a7ce20..0e4a10a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -15,22 +15,13 @@ add_library(sample sample.cpp)
target_link_libraries(sample frac)
add_executable(fracture fracture.cpp)
-target_link_libraries(fracture frac measurements fftw3 cholmod profiler GL GLU glut)
-
-add_executable(fracture_square fracture_square.cpp)
-target_link_libraries(fracture_square frac measurements fftw3 cholmod profiler GL GLU glut)
+target_link_libraries(fracture frac measurements cholmod)
add_executable(animate_fracture animate_fracture.cpp)
-target_link_libraries(animate_fracture frac animate fftw3 cholmod profiler GL GLU glut)
-
-add_executable(animate_fracture_square animate_fracture_square.cpp)
-target_link_libraries(animate_fracture_square frac animate fftw3 cholmod profiler GL GLU glut)
+target_link_libraries(animate_fracture frac animate cholmod GL GLU glut)
add_executable(sample_fracture sample_fracture.cpp)
target_link_libraries(sample_fracture frac sample cholmod)
-add_executable(sample_fracture_square sample_fracture_square.cpp)
-target_link_libraries(sample_fracture_square frac sample cholmod)
-
add_executable(percolation percolation.cpp)
-target_link_libraries(percolation frac perc_meas fftw3 cholmod profiler GL GLU glut)
+target_link_libraries(percolation frac perc_meas cholmod)