summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3cb6aeb..1e0a7f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
-cmake_minimum_required(VERSION 3.7)
+cmake_minimum_required(VERSION 3.5)
project(fracture)
include_directories(src ~/.local/include)
@@ -15,5 +15,6 @@ foreach( src_file ${EXE_SOURCES} )
string( REGEX REPLACE ".*/src/(.*)\.c" "\\1" exe_name ${src_file} )
add_executable( ${exe_name} ${src_file} )
target_link_libraries(${exe_name} fracture_stuff gsl c cblas lapack dl pthread cholmod amd colamd suitesparseconfig camd ccolamd rt metis m jst tcmalloc profiler)
+ install(TARGETS ${exe_name} DESTINATION bin)
endforeach( src_file ${EXE_SOURCES} )