summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..ade950f
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,20 @@
+
+cmake_minimum_required(VERSION 3.5)
+project(fracture)
+
+include_directories(src ~/.local/include /usr/include/suitesparse)
+link_directories(~/.local/lib)
+
+file(GLOB LIB_SOURCES lib/*.c)
+
+add_library(fracture_stuff ${LIB_SOURCES})
+
+file(GLOB EXE_SOURCES src/*.c)
+
+foreach( src_file ${EXE_SOURCES} )
+ string( REGEX REPLACE ".*/src/(.*)\.c" "\\1" exe_name ${src_file} )
+ add_executable( ${exe_name} ${src_file} )
+ target_link_libraries(${exe_name} fracture_stuff gsl c cblas lapack dl pthread cholmod amd colamd suitesparseconfig camd ccolamd rt metis m jst tcmalloc profiler)
+ install(TARGETS ${exe_name} DESTINATION bin)
+endforeach( src_file ${EXE_SOURCES} )
+