summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2018-07-26 16:18:40 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2018-07-26 16:18:40 -0400
commit1160baa61bad605cf8a1d583e8ae356a54a942df (patch)
treee7c865f38836a9a03349bbd803aae8be9b37a200 /CMakeLists.txt
parent870555f569bc63fecdc7c0b16e72e4e002f21c13 (diff)
downloadc++-1160baa61bad605cf8a1d583e8ae356a54a942df.tar.gz
c++-1160baa61bad605cf8a1d583e8ae356a54a942df.tar.bz2
c++-1160baa61bad605cf8a1d583e8ae356a54a942df.zip
many changes, including new spin spaces and groups and cleaning up core library code
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fe564f7..12fe087 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,7 @@ add_executable(wolff_4potts src/wolff_potts.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_7potts src/wolff_potts.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_3clock src/wolff_clock.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_5clock src/wolff_clock.cpp ${CPPSOURCES} ${CSOURCES})
+add_executable(wolff_planar2 src/wolff_O2.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_planar src/wolff_On.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_heisenberg src/wolff_On.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(analyze_correlations src/analyze_correlations.cpp ${CPPSOURCES} ${CSOURCES})
@@ -54,6 +55,7 @@ if (${GLUT} MATCHES "GLUT-NOTFOUND")
target_link_libraries(wolff_5clock cblas gsl m)
target_link_libraries(wolff_heisenberg cblas gsl m)
target_link_libraries(wolff_planar cblas gsl m)
+ target_link_libraries(wolff_planar2 cblas gsl m)
else()
target_link_libraries(wolff_ising cblas gsl m glut GL GLU)
target_link_libraries(wolff_dgm cblas gsl m glut GL GLU)
@@ -65,6 +67,7 @@ else()
target_link_libraries(wolff_5clock cblas gsl m glut GL GLU)
target_link_libraries(wolff_heisenberg cblas gsl m glut GL GLU)
target_link_libraries(wolff_planar cblas gsl m glut GL GLU)
+ target_link_libraries(wolff_planar2 cblas gsl m glut GL GLU)
target_compile_definitions(wolff_ising PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_dgm PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_cgm PUBLIC HAVE_GLUT)
@@ -74,6 +77,7 @@ else()
target_compile_definitions(wolff_3clock PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_5clock PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_planar PUBLIC HAVE_GLUT)
+ target_compile_definitions(wolff_planar2 PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_heisenberg PUBLIC HAVE_GLUT)
endif()