summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2018-03-20 19:06:50 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2018-03-20 19:06:50 -0400
commit2928df0a4b4be30cde2b11bdcf2698875d5b9536 (patch)
tree38116f528ff090610ec9463064fd1296af7967b6 /CMakeLists.txt
parentaf50f36935953b096fba19113ae5b0a602278796 (diff)
downloadc++-2928df0a4b4be30cde2b11bdcf2698875d5b9536.tar.gz
c++-2928df0a4b4be30cde2b11bdcf2698875d5b9536.tar.bz2
c++-2928df0a4b4be30cde2b11bdcf2698875d5b9536.zip
new system
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3b0de87..1b00bfc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,7 @@ link_directories(~/.local/lib)
file(GLOB SOURCES lib/*.c)
add_executable(wolff_potts src/wolff_potts.c ${SOURCES})
add_executable(wolff_vector src/wolff_vector.c ${SOURCES})
+add_executable(wolff_dgm src/wolff_dgm.c ${SOURCES})
find_package(OpenMP)
if (OPENMP_FOUND)
@@ -19,6 +20,7 @@ endif()
target_link_libraries(wolff_potts gsl m cblas fftw3)
target_link_libraries(wolff_vector gsl m cblas fftw3)
+target_link_libraries(wolff_dgm gsl m cblas fftw3)
-install(TARGETS wolff_potts wolff_vector DESTINATION bin)
+install(TARGETS wolff_potts wolff_vector wolff_dgm DESTINATION bin)