summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2018-06-28 14:20:25 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2018-06-28 14:20:25 -0400
commit3eb67e3bca774eb0441db60158e1968ad901273b (patch)
tree5250190f9230b129b4d82a9d23cc5ae6547a6b8d /CMakeLists.txt
parent25781a4041fa75a3394949d111be3abbefc97c26 (diff)
downloadc++-3eb67e3bca774eb0441db60158e1968ad901273b.tar.gz
c++-3eb67e3bca774eb0441db60158e1968ad901273b.tar.bz2
c++-3eb67e3bca774eb0441db60158e1968ad901273b.zip
cleaned up the operation of the finite-group wolff code
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2ef18d5..4b46bcd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,7 +10,7 @@ include_directories(lib ~/.local/include)
link_directories(~/.local/lib)
file(GLOB SOURCES lib/*.c)
-add_executable(wolff_potts src/wolff_potts.c ${SOURCES})
+add_executable(wolff_finite src/wolff_finite.c ${SOURCES})
add_executable(wolff_vector src/wolff_vector.c ${SOURCES})
add_executable(wolff_dgm src/wolff_dgm.c ${SOURCES})
@@ -20,9 +20,9 @@ if (OPENMP_FOUND)
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${OpenMP_CXX_FLAGS}")
endif()
-target_link_libraries(wolff_potts gsl m cblas fftw3)
+target_link_libraries(wolff_finite gsl m cblas fftw3)
target_link_libraries(wolff_vector gsl m cblas fftw3)
target_link_libraries(wolff_dgm gsl m cblas fftw3)
-install(TARGETS wolff_potts wolff_vector wolff_dgm DESTINATION bin)
+install(TARGETS wolff_finite wolff_vector wolff_dgm DESTINATION bin)