summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2018-10-10 00:08:11 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2018-10-10 00:08:11 -0400
commit4239e2bfc6701f0b5170132d01af381129618b34 (patch)
treef3429fc52a950f5fbd756d6fa0e5863e52b35393 /CMakeLists.txt
parentb01aedbf7d9cb6bdcdd291e6d4a66f3ef8fa7eb4 (diff)
downloadc++-4239e2bfc6701f0b5170132d01af381129618b34.tar.gz
c++-4239e2bfc6701f0b5170132d01af381129618b34.tar.bz2
c++-4239e2bfc6701f0b5170132d01af381129618b34.zip
added new compile flag NOFIELD, which when defined compiles a version of wolff for use with zero field
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 568585f..89c55a6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,7 @@ add_executable(wolff_3clock src/wolff_clock.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_5clock src/wolff_clock.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_planar src/wolff_On.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_planar_2D src/wolff_On.cpp ${CPPSOURCES} ${CSOURCES})
+add_executable(wolff_planar_2D_0 src/wolff_On.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_heisenberg src/wolff_On.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(analyze_correlations src/analyze_correlations.cpp ${CPPSOURCES} ${CSOURCES})
@@ -34,6 +35,7 @@ SET_TARGET_PROPERTIES(wolff_3clock PROPERTIES COMPILE_FLAGS "-DPOTTSQ=3")
SET_TARGET_PROPERTIES(wolff_5clock PROPERTIES COMPILE_FLAGS "-DPOTTSQ=5")
SET_TARGET_PROPERTIES(wolff_planar PROPERTIES COMPILE_FLAGS "-DN_COMP=2")
SET_TARGET_PROPERTIES(wolff_planar_2D PROPERTIES COMPILE_FLAGS "-DN_COMP=2 -DDIMENSION=2")
+SET_TARGET_PROPERTIES(wolff_planar_2D_0 PROPERTIES COMPILE_FLAGS "-DN_COMP=2 -DDIMENSION=2 -DNOFIELD")
SET_TARGET_PROPERTIES(wolff_heisenberg PROPERTIES COMPILE_FLAGS "-DN_COMP=3")
find_library(GSL REQUIRED NAMES gsl)
@@ -57,6 +59,7 @@ if (${GLUT} MATCHES "GLUT-NOTFOUND")
target_link_libraries(wolff_heisenberg cblas gsl m)
target_link_libraries(wolff_planar cblas gsl m)
target_link_libraries(wolff_planar_2D cblas gsl m)
+ target_link_libraries(wolff_planar_2D_0 cblas gsl m)
else()
target_link_libraries(wolff_ising cblas gsl m glut GL GLU)
target_link_libraries(wolff_dgm cblas gsl m glut GL GLU)
@@ -69,6 +72,7 @@ else()
target_link_libraries(wolff_heisenberg cblas gsl m glut GL GLU)
target_link_libraries(wolff_planar cblas gsl m glut GL GLU)
target_link_libraries(wolff_planar_2D cblas gsl m glut GL GLU)
+ target_link_libraries(wolff_planar_2D_0 cblas gsl m glut GL GLU)
target_compile_definitions(wolff_ising PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_dgm PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_cgm PUBLIC HAVE_GLUT)