summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2018-07-09 14:19:16 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2018-07-09 14:19:16 -0400
commit466812e61e2ccec7750c791835111b402938411c (patch)
tree09b46ec932ce6b31b8093580d500b91bb0e19bb7 /CMakeLists.txt
parentdc72eb1fa4a476eade0ade98a463e7c96000fb0d (diff)
downloadc++-466812e61e2ccec7750c791835111b402938411c.tar.gz
c++-466812e61e2ccec7750c791835111b402938411c.tar.bz2
c++-466812e61e2ccec7750c791835111b402938411c.zip
wolff run from own function, called with types to run
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7c1bc32..ffbde47 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,7 +12,8 @@ link_directories(~/.local/lib)
file(GLOB CSOURCES lib/*.c)
file(GLOB CPPSOURCES lib/*.cpp)
add_executable(wolff_finite src/wolff_finite.c ${CSOURCES})
-add_executable(wolff src/wolff.cpp ${CPPSOURCES} ${CSOURCES})
+add_executable(wolff_heisenberg src/wolff_heisenberg.cpp ${CPPSOURCES} ${CSOURCES})
+add_executable(wolff_planar src/wolff_planar.cpp ${CPPSOURCES} ${CSOURCES})
find_package(OpenMP)
if (OPENMP_FOUND)
@@ -21,7 +22,8 @@ if (OPENMP_FOUND)
endif()
target_link_libraries(wolff_finite gsl m cblas fftw3)
-target_link_libraries(wolff gsl m cblas fftw3)
+target_link_libraries(wolff_heisenberg gsl m cblas fftw3)
+target_link_libraries(wolff_planar gsl m cblas fftw3)
-install(TARGETS wolff_finite wolff DESTINATION bin)
+install(TARGETS wolff_finite wolff_heisenberg wolff_planar DESTINATION bin)