summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2018-07-20 22:57:39 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2018-07-20 22:57:39 -0400
commit5ffaf0a1bb0f0b47d57d0f24ee1134659775dacb (patch)
tree230c9562222b7858316ac1bb59bb3e8570746df4 /CMakeLists.txt
parent72301b3d5c3a91ff2e7fc6eedcad7bce8e647efa (diff)
downloadc++-5ffaf0a1bb0f0b47d57d0f24ee1134659775dacb.tar.gz
c++-5ffaf0a1bb0f0b47d57d0f24ee1134659775dacb.tar.bz2
c++-5ffaf0a1bb0f0b47d57d0f24ee1134659775dacb.zip
added ising example to cpp collection
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 98ef947..f9ee423 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,7 @@ file(GLOB CSOURCES lib/*.c)
file(GLOB CPPSOURCES lib/*.cpp)
add_executable(wolff_finite src/wolff_finite.c ${CSOURCES})
+add_executable(wolff_ising src/wolff_ising.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_planar src/wolff_On.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_heisenberg src/wolff_On.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(analyze_correlations src/analyze_correlations.cpp ${CPPSOURCES} ${CSOURCES})
@@ -28,9 +29,10 @@ if (OPENMP_FOUND)
endif()
target_link_libraries(wolff_finite gsl cblas fftw3 m)
+target_link_libraries(wolff_ising gsl cblas fftw3 m)
target_link_libraries(wolff_heisenberg gsl cblas fftw3 m)
target_link_libraries(wolff_planar gsl cblas fftw3 m)
target_link_libraries(analyze_correlations gsl cblas fftw3 m)
-install(TARGETS wolff_finite wolff_heisenberg wolff_planar analyze_correlations DESTINATION bin)
+install(TARGETS wolff_finite wolff_ising wolff_heisenberg wolff_planar analyze_correlations DESTINATION bin)