summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2018-07-24 19:15:36 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2018-07-24 19:15:36 -0400
commitdbae5cf4f9b80edc8d089475d5de4c13478c4f40 (patch)
tree238885928001f0ece222281dc17a8b1ca6016e27 /CMakeLists.txt
parent96e878d2f69790dc72bb4b713c1d492fa2b4c587 (diff)
downloadc++-dbae5cf4f9b80edc8d089475d5de4c13478c4f40.tar.gz
c++-dbae5cf4f9b80edc8d089475d5de4c13478c4f40.tar.bz2
c++-dbae5cf4f9b80edc8d089475d5de4c13478c4f40.zip
removed c files that are no longer faster than the c++ ones
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b5a47d6..50bc708 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,6 @@ link_directories(~/.local/lib)
file(GLOB CSOURCES lib/*.c)
file(GLOB CPPSOURCES lib/*.cpp)
-add_executable(wolff_finite src/wolff_finite.c ${CSOURCES})
add_executable(wolff_ising src/wolff_ising.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_dgm src/wolff_dgm.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_cgm src/wolff_cgm.cpp ${CPPSOURCES} ${CSOURCES})
@@ -37,7 +36,6 @@ FIND_LIBRARY(GLU NAMES GLU)
FIND_LIBRARY(GLUT NAMES glut)
FIND_LIBRARY(TESTING NAMES Idontexist)
-target_link_libraries(wolff_finite cblas gsl m)
target_link_libraries(analyze_correlations cblas gsl fftw3 m)
if (${GLUT} MATCHES "GLUT-NOTFOUND")
target_link_libraries(wolff_ising cblas gsl m)
@@ -64,5 +62,5 @@ else()
target_compile_definitions(wolff_heisenberg PUBLIC HAVE_GLUT)
endif()
-install(TARGETS wolff_finite wolff_ising wolff_dgm wolff_cgm wolff_3potts wolff_4potts wolff_heisenberg wolff_planar analyze_correlations DESTINATION bin)
+install(TARGETS wolff_ising wolff_dgm wolff_cgm wolff_3potts wolff_4potts wolff_heisenberg wolff_planar analyze_correlations DESTINATION bin)