summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2018-07-22 01:20:29 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2018-07-22 01:20:29 -0400
commitdd2c47db3512658858685c83dd772603203aaab1 (patch)
treee029032fb62317237482844af9f1bbd3b5545c45 /CMakeLists.txt
parente74305e932e45c0d2e69fd1c0a7313662fc47375 (diff)
downloadc++-dd2c47db3512658858685c83dd772603203aaab1.tar.gz
c++-dd2c47db3512658858685c83dd772603203aaab1.tar.bz2
c++-dd2c47db3512658858685c83dd772603203aaab1.zip
potts now fully functional
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eedccaa..5269c48 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,10 +16,12 @@ file(GLOB CPPSOURCES lib/*.cpp)
add_executable(wolff_finite src/wolff_finite.c ${CSOURCES})
add_executable(wolff_ising src/wolff_ising.cpp ${CPPSOURCES} ${CSOURCES})
+add_executable(wolff_3potts src/wolff_potts.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_planar src/wolff_On.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_heisenberg src/wolff_On.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(analyze_correlations src/analyze_correlations.cpp ${CPPSOURCES} ${CSOURCES})
+SET_TARGET_PROPERTIES(wolff_3potts PROPERTIES COMPILE_FLAGS "-DPOTTSQ=3")
SET_TARGET_PROPERTIES(wolff_planar PROPERTIES COMPILE_FLAGS "-DN_COMP=2")
SET_TARGET_PROPERTIES(wolff_heisenberg PROPERTIES COMPILE_FLAGS "-DN_COMP=3")
@@ -35,16 +37,19 @@ target_link_libraries(wolff_finite cblas gsl m)
target_link_libraries(analyze_correlations cblas gsl fftw3 m)
if (${GLUT} MATCHES "GLUT-NOTFOUND")
target_link_libraries(wolff_ising cblas gsl m)
+ target_link_libraries(wolff_3potts cblas gsl m)
target_link_libraries(wolff_heisenberg cblas gsl m)
target_link_libraries(wolff_planar cblas gsl m)
else()
target_link_libraries(wolff_ising cblas gsl m glut GL GLU)
+ target_link_libraries(wolff_3potts cblas gsl m glut GL GLU)
target_link_libraries(wolff_heisenberg cblas gsl m glut GL GLU)
target_link_libraries(wolff_planar cblas gsl m glut GL GLU)
target_compile_definitions(wolff_ising PUBLIC HAVE_GLUT)
+ target_compile_definitions(wolff_3potts PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_planar PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_heisenberg PUBLIC HAVE_GLUT)
endif()
-install(TARGETS wolff_finite wolff_ising wolff_heisenberg wolff_planar analyze_correlations DESTINATION bin)
+install(TARGETS wolff_finite wolff_ising wolff_3potts wolff_heisenberg wolff_planar analyze_correlations DESTINATION bin)