summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2018-07-11 12:58:54 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2018-07-11 12:58:54 -0400
commitf1e962dfbeb09b1834e466ecf246764a7584946b (patch)
tree65cc5cfdbdbe71aeaf6ab69bfdfba77ea7086e6a /CMakeLists.txt
parente53a4c09eb78e4c5a8365f1328a69ba7f9ff8992 (diff)
downloadc++-f1e962dfbeb09b1834e466ecf246764a7584946b.tar.gz
c++-f1e962dfbeb09b1834e466ecf246764a7584946b.tar.bz2
c++-f1e962dfbeb09b1834e466ecf246764a7584946b.zip
added utility for extracting correlation functions from raw timeseries
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ffbde47..d00da5b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,9 +11,11 @@ link_directories(~/.local/lib)
file(GLOB CSOURCES lib/*.c)
file(GLOB CPPSOURCES lib/*.cpp)
+
add_executable(wolff_finite src/wolff_finite.c ${CSOURCES})
add_executable(wolff_heisenberg src/wolff_heisenberg.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_planar src/wolff_planar.cpp ${CPPSOURCES} ${CSOURCES})
+add_executable(analyze_correlations src/analyze_correlations.cpp ${CPPSOURCES} ${CSOURCES})
find_package(OpenMP)
if (OPENMP_FOUND)
@@ -24,6 +26,7 @@ endif()
target_link_libraries(wolff_finite gsl m cblas fftw3)
target_link_libraries(wolff_heisenberg gsl m cblas fftw3)
target_link_libraries(wolff_planar gsl m cblas fftw3)
+target_link_libraries(analyze_correlations gsl m cblas fftw3)
-install(TARGETS wolff_finite wolff_heisenberg wolff_planar DESTINATION bin)
+install(TARGETS wolff_finite wolff_heisenberg wolff_planar analyze_correlations DESTINATION bin)