summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2017-05-25 13:26:38 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2017-05-25 13:26:38 -0400
commitf7a21799194f6626994195302ac95449158bdcd9 (patch)
tree1b65f643f239f8abc8de015fe660486b11b3071e /CMakeLists.txt
downloadc++-f7a21799194f6626994195302ac95449158bdcd9.tar.gz
c++-f7a21799194f6626994195302ac95449158bdcd9.tar.bz2
c++-f7a21799194f6626994195302ac95449158bdcd9.zip
started wolff code in new repository
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..c325cb4
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,21 @@
+
+cmake_minimum_required(VERSION 3.7)
+project(wolff)
+
+include_directories(src ~/.local/include)
+link_directories(~/.local/lib)
+
+file(GLOB SOURCES lib/*.c)
+add_executable(wolff src/wolff.c ${SOURCES})
+
+find_package(OpenMP)
+if (OPENMP_FOUND)
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${OpenMP_C_FLAGS}")
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${OpenMP_CXX_FLAGS}")
+endif()
+
+target_link_libraries(wolff gsl m jst cblas fftw3 tcmalloc profiler)
+#target_link_libraries(pt_wolff gsl m jst cblas tcmalloc profiler)
+
+install(TARGETS wolff DESTINATION bin)
+