summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 50bc708..b391bba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,12 +19,16 @@ add_executable(wolff_dgm src/wolff_dgm.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_cgm src/wolff_cgm.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_3potts src/wolff_potts.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_4potts src/wolff_potts.cpp ${CPPSOURCES} ${CSOURCES})
+add_executable(wolff_3clock src/wolff_clock.cpp ${CPPSOURCES} ${CSOURCES})
+add_executable(wolff_5clock src/wolff_clock.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_planar src/wolff_On.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_heisenberg src/wolff_On.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(analyze_correlations src/analyze_correlations.cpp ${CPPSOURCES} ${CSOURCES})
SET_TARGET_PROPERTIES(wolff_3potts PROPERTIES COMPILE_FLAGS "-DPOTTSQ=3")
SET_TARGET_PROPERTIES(wolff_4potts PROPERTIES COMPILE_FLAGS "-DPOTTSQ=4")
+SET_TARGET_PROPERTIES(wolff_3clock PROPERTIES COMPILE_FLAGS "-DPOTTSQ=3")
+SET_TARGET_PROPERTIES(wolff_5clock PROPERTIES COMPILE_FLAGS "-DPOTTSQ=5")
SET_TARGET_PROPERTIES(wolff_planar PROPERTIES COMPILE_FLAGS "-DN_COMP=2")
SET_TARGET_PROPERTIES(wolff_heisenberg PROPERTIES COMPILE_FLAGS "-DN_COMP=3")
@@ -43,6 +47,8 @@ if (${GLUT} MATCHES "GLUT-NOTFOUND")
target_link_libraries(wolff_cgm cblas gsl m)
target_link_libraries(wolff_3potts cblas gsl m)
target_link_libraries(wolff_4potts cblas gsl m)
+ target_link_libraries(wolff_3clock cblas gsl m)
+ target_link_libraries(wolff_5clock cblas gsl m)
target_link_libraries(wolff_heisenberg cblas gsl m)
target_link_libraries(wolff_planar cblas gsl m)
else()
@@ -51,16 +57,20 @@ else()
target_link_libraries(wolff_cgm cblas gsl m glut GL GLU)
target_link_libraries(wolff_3potts cblas gsl m glut GL GLU)
target_link_libraries(wolff_4potts cblas gsl m glut GL GLU)
+ target_link_libraries(wolff_3clock cblas gsl m glut GL GLU)
+ target_link_libraries(wolff_5clock cblas gsl m glut GL GLU)
target_link_libraries(wolff_heisenberg cblas gsl m glut GL GLU)
target_link_libraries(wolff_planar cblas gsl m glut GL GLU)
target_compile_definitions(wolff_ising PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_dgm PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_cgm PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_3potts PUBLIC HAVE_GLUT)
+ target_compile_definitions(wolff_3clock PUBLIC HAVE_GLUT)
+ target_compile_definitions(wolff_5clock PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_4potts PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_planar PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_heisenberg PUBLIC HAVE_GLUT)
endif()
-install(TARGETS wolff_ising wolff_dgm wolff_cgm wolff_3potts wolff_4potts wolff_heisenberg wolff_planar analyze_correlations DESTINATION bin)
+install(TARGETS wolff_ising wolff_dgm wolff_cgm wolff_3potts wolff_4potts wolff_3clock wolff_heisenberg wolff_planar analyze_correlations DESTINATION bin)