summaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 634c600..fcb6c0f 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -2,6 +2,8 @@
add_executable(ising ising.cpp)
add_executable(ising_animation ising_animation.cpp)
add_executable(ising_standalone ising_standalone.cpp)
+add_executable(ising_random_field ising_random_field.cpp)
+add_executable(ising_no_field ising_no_field.cpp)
add_executable(xy On.cpp)
add_executable(potts_3 potts.cpp)
add_executable(clock_5 clock.cpp)
@@ -15,6 +17,8 @@ target_compile_definitions(clock_5 PUBLIC WOLFF_POTTSQ=5)
target_link_libraries(ising wolff)
target_link_libraries(ising_animation wolff GL GLU glut)
target_link_libraries(ising_standalone wolff)
+target_link_libraries(ising_random_field wolff)
+target_link_libraries(ising_no_field wolff)
target_link_libraries(xy wolff)
target_link_libraries(potts_3 wolff)
target_link_libraries(clock_5 wolff)