summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2020-02-25 17:21:47 -0500
committerJaron Kent-Dobias <jaron@kent-dobias.com>2020-02-25 17:21:47 -0500
commit566f3d3246e73ffbf27bc2294f2263a875d878d9 (patch)
tree0027f2a9e7a0442664d02b3c2bd0c9fc052fc882
parent6437967ea61e983e3c99088adcdc44e77efb16c5 (diff)
downloadlinux-pinebook-566f3d3246e73ffbf27bc2294f2263a875d878d9.tar.gz
linux-pinebook-566f3d3246e73ffbf27bc2294f2263a875d878d9.tar.bz2
linux-pinebook-566f3d3246e73ffbf27bc2294f2263a875d878d9.zip
Several changes
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 664daff..385cc56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# AArch64 multi-platform with Pine64 support
-# Maintainer: Vasily Khoruzhick <anarsoul@gmail.com>
+# Maintainer: Jaron Kent-Dobias <jaron@kent-dobias.com>
+# Contributor: Vasily Khoruzhick <anarsoul@gmail.com>
buildarch=8
_ver=5.6
-pkgbase=linux-pine64
-_srctag=v5.6-pine64-9
-_srcname=pine64-linux
+pkgbase=linux-pinebook
+pkgver=5.6.pinebook10
+pkgrel=1
+_desc="AArch64 multi-platform with Pinebook support."
+_srctag=v${pkgver%.*}-${pkgver##*.}
+url="https://git.kent-dobias.com/system/linux/log/?h=$_srctag"
_kernelname=${pkgbase#linux}
-_desc="AArch64 multi-platform with Pine64 support"
-pkgver=5.6
-pkgrel=9
arch=('aarch64')
-url="http://www.kernel.org/"
license=('GPL2')
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git' 'uboot-tools' 'dtc')
options=('!strip')
+_srcname=pinebook-linux
source=(
"$_srcname::git+https://git.kent-dobias.com/system/linux?signed#tag=$_srctag"
'config'
@@ -62,7 +63,7 @@ build() {
# Configure the kernel. Replace the line below with one of your choice.
#make menuconfig # CLI menu for configuration
#make nconfig # new CLI menu for configuration
- make xconfig # X-based configuration
+ #make xconfig # X-based configuration
#make oldconfig # using old config from previous kernel version
# ... or manually edit .config