summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2022-06-28 12:26:56 +0200
committerJaron Kent-Dobias <jaron@kent-dobias.com>2022-06-28 12:26:56 +0200
commit7884442c2b6eca70f4e2a3b41132386cb806c62b (patch)
treeb00bd9a39aa79bddd6da8f2533a6d815bfb3a9ed /PKGBUILD
parent40c3e539799a8e209a35a1f7b83da26d5d294c6f (diff)
downloadlinux-pinephone-7884442c2b6eca70f4e2a3b41132386cb806c62b.tar.gz
linux-pinephone-7884442c2b6eca70f4e2a3b41132386cb806c62b.tar.bz2
linux-pinephone-7884442c2b6eca70f4e2a3b41132386cb806c62b.zip
Enabled useful module.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 438cffc..54c97af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgbase=linux-pinephone
-pkgver=5.18.7.pp1
-pkgrel=1
+pkgver=5.18.7.pp2
+pkgrel=3
pkgdesc='Pinephone Linux'
_srctag=v${pkgver%.*}-${pkgver##*.}
url="https://git.kent-dobias.com/system/linux/log/?h=$_srctag"
@@ -30,7 +30,7 @@ validpgpkeys=(
'0E3A444DD0760E65901BF59679E824090BD31086' # Jaron Kent-Dobias
)
sha256sums=('SKIP'
- '883047070706e416f140f28c4d02a0e8e96c8a8f21c1137ec17e7e07f85ab8f8')
+ '6af28259eca634eb476f5f770c01f4890d10d9a67e6fd1ec2b16b508a5671347')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
@@ -66,6 +66,7 @@ prepare() {
build() {
cd $_srcname
$_make all
+ # Generate device tree blobs with symbols to support applying device tree overlays in U-Boot
# $_make htmldocs
}
@@ -84,6 +85,7 @@ _package() {
echo "Installing boot image..."
install -Dm644 arch/arm64/boot/Image "${pkgdir}/boot/Image"
+ install -Dm644 arch/arm64/boot/Image.gz "${pkgdir}/boot/Image.gz"
# systemd expects to find the kernel here to allow hibernation
# https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344