summaryrefslogtreecommitdiff
path: root/config
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2025-01-04 10:20:31 +0100
committerJaron Kent-Dobias <jaron@kent-dobias.com>2025-01-04 10:20:31 +0100
commit90aafc9e094fa90f4ede9aae82428c091513da6e (patch)
tree88d83e331b6d77887546d2c733448989caf97a2c /config
parentec272fab0a608dac3b5d5db83cc8723e0f13c863 (diff)
downloadlinux-raspberrypi4-90aafc9e094fa90f4ede9aae82428c091513da6e.tar.gz
linux-raspberrypi4-90aafc9e094fa90f4ede9aae82428c091513da6e.tar.bz2
linux-raspberrypi4-90aafc9e094fa90f4ede9aae82428c091513da6e.zip
Updated to 6.12.8
Diffstat (limited to 'config')
-rw-r--r--config16
1 files changed, 8 insertions, 8 deletions
diff --git a/config b/config
index 5c824d0..53512e6 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/arm64 6.12.1-rpi1 Kernel Configuration
+# Linux/arm64 6.12.8-rpi1 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="clang version 18.1.8"
CONFIG_GCC_VERSION=0
@@ -18,7 +18,7 @@ CONFIG_CC_HAS_ASM_GOTO_TIED_OUTPUT=y
CONFIG_TOOLS_SUPPORT_RELR=y
CONFIG_CC_HAS_ASM_INLINE=y
CONFIG_CC_HAS_NO_PROFILE_FN_ATTR=y
-CONFIG_PAHOLE_VERSION=127
+CONFIG_PAHOLE_VERSION=128
CONFIG_IRQ_WORK=y
CONFIG_BUILDTIME_TABLE_SORT=y
CONFIG_THREAD_INFO_IN_TASK=y
@@ -388,6 +388,7 @@ CONFIG_CAVIUM_ERRATUM_30115=y
CONFIG_CAVIUM_TX2_ERRATUM_219=y
CONFIG_FUJITSU_ERRATUM_010001=y
CONFIG_HISILICON_ERRATUM_161600802=y
+CONFIG_HISILICON_ERRATUM_162100801=y
CONFIG_QCOM_FALKOR_ERRATUM_1003=y
CONFIG_QCOM_FALKOR_ERRATUM_1009=y
CONFIG_QCOM_QDF2400_ERRATUM_0065=y
@@ -1941,6 +1942,7 @@ CONFIG_RASPBERRYPI_FIRMWARE=y
# CONFIG_FW_CFG_SYSFS is not set
# CONFIG_ARM_FFA_TRANSPORT is not set
# CONFIG_GOOGLE_FIRMWARE is not set
+# CONFIG_IMX_SCMI_MISC_DRV is not set
CONFIG_ARM_PSCI_FW=y
#
@@ -1978,7 +1980,6 @@ CONFIG_BLK_DEV=y
# CONFIG_BLK_DEV_NULL_BLK is not set
# CONFIG_BLK_DEV_PCIESSD_MTIP32XX is not set
# CONFIG_ZRAM is not set
-CONFIG_ZRAM_DEF_COMP="unset-value"
CONFIG_BLK_DEV_LOOP=y
CONFIG_BLK_DEV_LOOP_MIN_COUNT=8
# CONFIG_BLK_DEV_DRBD is not set
@@ -2009,7 +2010,6 @@ CONFIG_BLK_DEV_NVME=y
# Misc devices
#
CONFIG_BCM2835_SMI=m
-# CONFIG_RP1_PIO is not set
# CONFIG_AD525X_DPOT is not set
# CONFIG_DUMMY_IRQ is not set
# CONFIG_PHANTOM is not set
@@ -2948,6 +2948,7 @@ CONFIG_SERIAL_CORE_CONSOLE=y
# CONFIG_SERIAL_FSL_LINFLEXUART is not set
# CONFIG_SERIAL_CONEXANT_DIGICOLOR is not set
# CONFIG_SERIAL_SPRD is not set
+# CONFIG_SERIAL_RPI_FW is not set
# end of Serial drivers
CONFIG_SERIAL_MCTRL_GPIO=y
@@ -4805,6 +4806,7 @@ CONFIG_FB_SYS_IMAGEBLIT=y
CONFIG_FB_SYSMEM_FOPS=y
CONFIG_FB_DEFERRED_IO=y
CONFIG_FB_DMAMEM_HELPERS=y
+CONFIG_FB_DMAMEM_HELPERS_DEFERRED=y
CONFIG_FB_IOMEM_FOPS=y
CONFIG_FB_IOMEM_HELPERS=y
CONFIG_FB_SYSMEM_HELPERS=y
@@ -6497,7 +6499,7 @@ CONFIG_HARDENED_USERCOPY=y
# CONFIG_SECURITY_TOMOYO is not set
# CONFIG_SECURITY_APPARMOR is not set
# CONFIG_SECURITY_LOADPIN is not set
-# CONFIG_SECURITY_YAMA is not set
+CONFIG_SECURITY_YAMA=y
# CONFIG_SECURITY_SAFESETID is not set
# CONFIG_SECURITY_LOCKDOWN_LSM is not set
CONFIG_SECURITY_LANDLOCK=y
@@ -6508,7 +6510,7 @@ CONFIG_INTEGRITY_AUDIT=y
# CONFIG_IMA is not set
# CONFIG_EVM is not set
CONFIG_DEFAULT_SECURITY_DAC=y
-CONFIG_LSM="lockdown,yama,loadpin,safesetid,integrity"
+CONFIG_LSM="landlock,lockdown,yama,integrity,bpf"
#
# Kernel hardening options
@@ -7026,8 +7028,6 @@ CONFIG_SCHED_INFO=y
# CONFIG_SCHEDSTATS is not set
# end of Scheduler Debugging
-# CONFIG_DEBUG_TIMEKEEPING is not set
-
#
# Lock Debugging (spinlocks, mutexes, etc...)
#