summaryrefslogtreecommitdiff
path: root/prepare-lastboot.install
diff options
context:
space:
mode:
Diffstat (limited to 'prepare-lastboot.install')
-rwxr-xr-xprepare-lastboot.install13
1 files changed, 13 insertions, 0 deletions
diff --git a/prepare-lastboot.install b/prepare-lastboot.install
new file mode 100755
index 0000000..48a20ae
--- /dev/null
+++ b/prepare-lastboot.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo "For the lastboot EFI entry to boot the correct filesystem,"
+ echo "the kernel command line of the UKI must be amended. If your"
+ echo "root filesystem is zroot/root/default, you can run"
+ echo ""
+ echo "# /usr/lib/systemd/ukify build --cmdline \"root=zfs:zroot/root/lastboot-default\" \\"
+ echo "# --output=/efi/EFI/Linux/lastboot-default.efi.extra.d/cmdline.addon.efi"
+ echo ""
+ echo "and sign the restulting file, if necessary. The service is"
+ echo "enabled by running"
+ echo ""
+ echo "# systemctl enable prepare-lastboot@default.timer"
+}