summaryrefslogtreecommitdiff
path: root/uboot-pinebook.install
diff options
context:
space:
mode:
authorDan Johansen <strit@manjaro.org>2020-03-06 20:26:32 +0100
committerDan Johansen <strit@manjaro.org>2020-03-06 20:26:32 +0100
commitafc63120509619422b86df3d61536be7245e28f8 (patch)
tree7dffbe41af9410516b6e33db344ad1b4fd262818 /uboot-pinebook.install
downloaduboot-pinebook-afc63120509619422b86df3d61536be7245e28f8.tar.gz
uboot-pinebook-afc63120509619422b86df3d61536be7245e28f8.tar.bz2
uboot-pinebook-afc63120509619422b86df3d61536be7245e28f8.zip
initial commit
Diffstat (limited to 'uboot-pinebook.install')
-rw-r--r--uboot-pinebook.install17
1 files changed, 17 insertions, 0 deletions
diff --git a/uboot-pinebook.install b/uboot-pinebook.install
new file mode 100644
index 0000000..801363d
--- /dev/null
+++ b/uboot-pinebook.install
@@ -0,0 +1,17 @@
+flash_uboot() {
+ echo "Install new bootloader by running:"
+ echo "# dd if=/boot/u-boot-sunxi-with-spl-pinebook.bin of=/dev/mmcblk0 bs=8k seek=1 for Pinebook SD"
+ echo "# dd if=/boot/u-boot-sunxi-with-spl-pinebook.bin of=/dev/mmcblk2 bs=8k seek=1 for Pinebook eMMC"
+}
+
+## arg 1: the new package version
+post_install() {
+ flash_uboot
+ sed -i s/"LABEL=ROOT"/"LABEL=ROOT_MNJRO"/g /boot/extlinux/extlinux.conf
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ flash_uboot
+}