summaryrefslogtreecommitdiff
path: root/0001-ATF-set-fno-stack-protector.patch
diff options
context:
space:
mode:
Diffstat (limited to '0001-ATF-set-fno-stack-protector.patch')
-rw-r--r--0001-ATF-set-fno-stack-protector.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/0001-ATF-set-fno-stack-protector.patch b/0001-ATF-set-fno-stack-protector.patch
new file mode 100644
index 0000000..47721b4
--- /dev/null
+++ b/0001-ATF-set-fno-stack-protector.patch
@@ -0,0 +1,26 @@
+From 45018dbfb301759c9debff598a509832e35854a9 Mon Sep 17 00:00:00 2001
+From: Kevin Mihelich <kevin@archlinuxarm.org>
+Date: Sat, 19 Aug 2017 15:28:38 -0600
+Subject: [PATCH] ATF: set -fno-stack-protector
+
+---
+ Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 74d51804..0af9b350 100644
+--- a/Makefile
++++ b/Makefile
+@@ -202,7 +202,8 @@ ASFLAGS += $(CPPFLAGS) $(ASFLAGS_$(ARCH)) \
+ -Wa,--fatal-warnings
+ TF_CFLAGS += $(CPPFLAGS) $(TF_CFLAGS_$(ARCH)) \
+ -ffreestanding -fno-builtin -Wall -std=gnu99 \
+- -Os -ffunction-sections -fdata-sections
++ -Os -ffunction-sections -fdata-sections \
++ -fno-stack-protector
+
+ GCC_V_OUTPUT := $(shell $(CC) -v 2>&1)
+
+--
+2.19.1
+