summaryrefslogtreecommitdiff
path: root/uboot-pinebook.install
diff options
context:
space:
mode:
Diffstat (limited to 'uboot-pinebook.install')
-rw-r--r--uboot-pinebook.install24
1 files changed, 0 insertions, 24 deletions
diff --git a/uboot-pinebook.install b/uboot-pinebook.install
index 9159889..cbc5fef 100644
--- a/uboot-pinebook.install
+++ b/uboot-pinebook.install
@@ -6,32 +6,8 @@ flash_uboot() {
post_install() {
flash_uboot
- if [ -f /boot/extlinux/extlinux.conf.pacsave ]; then
- mv /boot/extlinux/extlinux.conf.pacsave /boot/extlinux/extlinux.conf
- fi
- if [ -f /boot/extlinux/extlinux.conf ]; then
- echo "Keeping old extlinux.conf file..."
- else
- mkdir -p /boot/extlinux/
- echo "LABEL Manjaro ARM
-KERNEL /Image
-FDT /dtbs/allwinner/sun50i-a64-pinebook.dtb
-APPEND initrd=/initramfs-linux.img console=tty1 console=ttyS0,115200 root=LABEL=ROOT_MNJRO rw rootwait bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash" > /boot/extlinux/extlinux.conf
- fi
}
post_upgrade() {
flash_uboot
- if [ -f /boot/extlinux/extlinux.conf.pacsave ]; then
- mv /boot/extlinux/extlinux.conf.pacsave /boot/extlinux/extlinux.conf
- fi
- if [ -f /boot/extlinux/extlinux.conf ]; then
- echo "Keeping old extlinux.conf file..."
- else
- mkdir -p /boot/extlinux/
- echo "LABEL Manjaro ARM
-KERNEL /Image
-FDT /dtbs/allwinner/sun50i-a64-pinebook.dtb
-APPEND initrd=/initramfs-linux.img console=tty1 console=ttyS0,115200 root=LABEL=ROOT_MNJRO rw rootwait bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash" > /boot/extlinux/extlinux.conf
- fi
}