summaryrefslogtreecommitdiff
path: root/uboot-pinebook.install
diff options
context:
space:
mode:
Diffstat (limited to 'uboot-pinebook.install')
-rw-r--r--uboot-pinebook.install31
1 files changed, 26 insertions, 5 deletions
diff --git a/uboot-pinebook.install b/uboot-pinebook.install
index 2d33ecc..9159889 100644
--- a/uboot-pinebook.install
+++ b/uboot-pinebook.install
@@ -1,16 +1,37 @@
flash_uboot() {
echo "A new U-Boot version can be flashed onto your install drive. Please use lsblk to determine your drive, before proceeding."
- echo "# dd if=/boot/u-boot-sunxi-with-spl-pinebook.bin of=/dev/mmcblkX bs=8k seek=1"
+ echo "You can do this by running:"
+ echo "# dd if=/boot/u-boot-sunxi-with-spl-pinebook.bin of=/dev/mmcblkX bs=8k seek=1"
}
-## arg 1: the new package version
post_install() {
flash_uboot
- sed -i s/"LABEL=ROOT"/"LABEL=ROOT_MNJRO"/g /boot/extlinux/extlinux.conf
+ if [ -f /boot/extlinux/extlinux.conf.pacsave ]; then
+ mv /boot/extlinux/extlinux.conf.pacsave /boot/extlinux/extlinux.conf
+ fi
+ if [ -f /boot/extlinux/extlinux.conf ]; then
+ echo "Keeping old extlinux.conf file..."
+ else
+ mkdir -p /boot/extlinux/
+ echo "LABEL Manjaro ARM
+KERNEL /Image
+FDT /dtbs/allwinner/sun50i-a64-pinebook.dtb
+APPEND initrd=/initramfs-linux.img console=tty1 console=ttyS0,115200 root=LABEL=ROOT_MNJRO rw rootwait bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash" > /boot/extlinux/extlinux.conf
+ fi
}
-## arg 1: the new package version
-## arg 2: the old package version
post_upgrade() {
flash_uboot
+ if [ -f /boot/extlinux/extlinux.conf.pacsave ]; then
+ mv /boot/extlinux/extlinux.conf.pacsave /boot/extlinux/extlinux.conf
+ fi
+ if [ -f /boot/extlinux/extlinux.conf ]; then
+ echo "Keeping old extlinux.conf file..."
+ else
+ mkdir -p /boot/extlinux/
+ echo "LABEL Manjaro ARM
+KERNEL /Image
+FDT /dtbs/allwinner/sun50i-a64-pinebook.dtb
+APPEND initrd=/initramfs-linux.img console=tty1 console=ttyS0,115200 root=LABEL=ROOT_MNJRO rw rootwait bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash" > /boot/extlinux/extlinux.conf
+ fi
}