summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a5badd7..f88c6f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,11 @@ pkgrel=1
arch=('aarch64')
url="https://www.wolfram.com/raspberry-pi/"
license=('proprietary')
-depends=('armv6h-libs')
-source=("https://files.wolframcdn.com/raspbian/12.1.1.0/wolfram-engine_12.1.1+2020081901_armhf.deb")
-md5sums=('aed07c54dd14d9a4d87b7d266649ff80')
+depends=(armv6h-libs)
+source=("https://files.wolframcdn.com/raspbian/12.1.1.0/wolfram-engine_12.1.1+2020081901_armhf.deb"
+ "wolfram-engine-aarch64-ld_library.patch")
+md5sums=('aed07c54dd14d9a4d87b7d266649ff80'
+ '1ddf68872597028fa477a9448c769885')
options=(!strip)
# Compressing takes a long time and is not helpful for local installations.
@@ -23,6 +25,8 @@ package() {
cd ${pkgdir}
tar -xf ${srcdir}/data.tar.xz
+ patch --forward --strip=1 --input=${srcdir}/wolfram-engine-aarch64-ld_library.patch
+
mkdir usr/bin
ln -s /opt/Wolfram/WolframEngine/12.1/Executables/MathKernel usr/bin/MathKernel
ln -s /opt/Wolfram/WolframEngine/12.1/Executables/Mathematica usr/bin/Mathematica