summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..dd09915
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Jaron Kent-Dobias <jaron@kent-dobias.com>
+
+pkgbase=wolfram-engine
+pkgname=wolfram-engine-aarch64
+pkgver=12.0.1+2019062401
+pkgrel=1
+arch=('aarch64')
+url="https://www.wolfram.com/raspberry-pi/"
+license=('proprietary')
+depends=('armv6h-libs')
+source=("http://wac.36f4.edgecastcdn.net/0036F4/raspbian/wolfram-engine_12.0.1+2019062401_armhf.deb"
+ 'math.patch'
+ 'mathematica.patch'
+ 'wolfram.patch'
+ 'MathKernel.patch'
+ 'Mathematica.patch'
+ 'WolframKernel.patch')
+sha512sums=('f7f9423b0c6f4e566d85deae5bbd7f47eae04f23e87b2c3ed6d1c128d3e6d6faea9bf71834f8d936f14d198500368698d6a5322dd4fcd9cfd2288bc71e46c41e'
+ 'f617e1ee73f288b4e1f84358b91d7961831f8858a881c3d0a552409081cf4b3d94ec998ebe71fefde80f8d354c84cfcfad8a5846f85dc4ce8bc51099bb764234'
+ '5a5e3fea51c5147fdb3950a96206345b96e574b40d68615c7a9c500a0a243bb3cead469f7b86fc7ca7a565c1e9f23c8d78ec5a7018faf24c422c142647d0c8d7'
+ '4dfd7e188d4014ec0bd623da6438a923d7bcf558251bbd345f15ed54714d54ccf03394871ef8648c069edf5888425496b1c2f56a833545d7c20e336aa259cf5b'
+ 'e6536dfd8abfd59e53fe14ffeb4daaca5f232a43565c1a29dfdcd287e337760d044549d10ce7f06d9dbfdb90e1f59c6b7006afb9438e56ad5810e029a0617ece'
+ '29d6a84ad993af07c45e277543bed51afa449d1f7c2c0b2ed566c8d8a1a4a4767d7a83a05f0cb00ca63eeb85a374bdd29bbc36b7e3e92d23b5049cf0002e5daf'
+ 'ccff08bc7fb01eabcc056c69e2786ef80c4c94a5eb9af349c6c526c620c9649a58ddbcc74d00859df0eeb97e48d74c19eb97a8869e21976af5b2dead2a148f58')
+options=(!strip)
+
+# Compressing takes a long time and is not helpful for local installations.
+PKGEXT='.pkg.tar'
+
+prepare() {
+ ar xv wolfram-engine_${pkgver}_armhf.deb
+}
+
+package() {
+ cd ${pkgdir}
+ tar -xf ${srcdir}/data.tar.xz
+
+ patch -p1 --input=../../MathKernel.patch
+ patch -p1 --input=../../Mathematica.patch
+ patch -p1 --input=../../WolframKernel.patch
+ patch -p1 --input=../../math.patch
+ patch -p1 --input=../../mathematica.patch
+ patch -p1 --input=../../wolfram.patch
+ patch -p1 --input=../../mcc.patch
+
+ mkdir usr/bin
+ ln -s /opt/Wolfram/WolframEngine/12.0/Executables/MathKernel usr/bin/MathKernel
+ ln -s /opt/Wolfram/WolframEngine/12.0/Executables/Mathematica usr/bin/Mathematica
+ ln -s /opt/Wolfram/WolframEngine/12.0/Executables/WolframKernel usr/bin/WolframKernel
+ ln -s /opt/Wolfram/WolframEngine/12.0/Executables/math usr/bin/math
+ ln -s /opt/Wolfram/WolframEngine/12.0/Executables/mathematica usr/bin/mathematica
+ ln -s /opt/Wolfram/WolframEngine/12.0/Executables/wolfram usr/bin/wolfram
+ ln -s /opt/Wolfram/WolframEngine/12.0/Executables/mcc usr/bin/mcc
+}