summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD10
-rwxr-xr-xwolframscript2
2 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80d30b3..6a35163 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,11 @@ pkgrel=1
arch=('aarch64')
url="https://www.wolfram.com/raspberry-pi/"
license=('proprietary')
-depends=()
-source=("https://files.wolframcdn.com/raspbian/12.1.1.0/wolframscript_1.4.0+2020081702_armhf.deb")
-sha512sums=('ccb8223da748abce72776fce9e7ea4de7c73f0540cccf59792262bffe7467e10d468cfb8a9e171a0994116430b7b9367990e84926375ba97fa1d8f3eb1ce75a6')
+depends=(armv6h-libs)
+source=("https://files.wolframcdn.com/raspbian/12.1.1.0/wolframscript_1.4.0+2020081702_armhf.deb"
+ "wolframscript")
+sha512sums=('ccb8223da748abce72776fce9e7ea4de7c73f0540cccf59792262bffe7467e10d468cfb8a9e171a0994116430b7b9367990e84926375ba97fa1d8f3eb1ce75a6'
+ 'd1cd427adb36f5b2ccaafb2a2f30269508716dc1cedc01f318d8a8db4f25309690d06f3c6e36673cd3c891740211a6be4e946d55023e0ce8fdee2375e8ac66f3')
options=(!strip)
prepare() {
@@ -21,5 +23,5 @@ package() {
tar -xf ${srcdir}/data.tar.xz
mkdir usr/bin
- ln -s /opt/Wolfram/WolframScript/bin/wolframscript usr/bin/wolframscript
+ cp ${srcdir}/wolframscript usr/bin/wolframscript
}
diff --git a/wolframscript b/wolframscript
new file mode 100755
index 0000000..bb5e8ab
--- /dev/null
+++ b/wolframscript
@@ -0,0 +1,2 @@
+#!/bin/sh
+LD_LIBRARY_PATH="/usr/libv6h:$LD_LIBRARY_PATH" /opt/Wolfram/WolframScript/bin/wolframscript