summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2018-02-28 20:33:41 -0500
committerJaron Kent-Dobias <jaron@kent-dobias.com>2018-02-28 20:33:41 -0500
commit1fbcb4dd4e52daeb53becba33827f8e48c5606b2 (patch)
tree6b8088fef6ca3e5f11551073b7793f6e9e767670 /CMakeLists.txt
parente0d4943090c285a44dad501cf9dc24714f9b3530 (diff)
downloadc++-1fbcb4dd4e52daeb53becba33827f8e48c5606b2.tar.gz
c++-1fbcb4dd4e52daeb53becba33827f8e48c5606b2.tar.bz2
c++-1fbcb4dd4e52daeb53becba33827f8e48c5606b2.zip
fixed major mistake in process, also got n-component version fully working
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eb86ba6..3b0de87 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,11 +2,14 @@
cmake_minimum_required(VERSION 3.0)
project(wolff)
+set (CMAKE_CXX_STANDARD 11)
+
include_directories(lib ~/.local/include)
link_directories(~/.local/lib)
file(GLOB SOURCES lib/*.c)
-add_executable(wolff src/wolff.c ${SOURCES})
+add_executable(wolff_potts src/wolff_potts.c ${SOURCES})
+add_executable(wolff_vector src/wolff_vector.c ${SOURCES})
find_package(OpenMP)
if (OPENMP_FOUND)
@@ -14,8 +17,8 @@ if (OPENMP_FOUND)
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${OpenMP_CXX_FLAGS}")
endif()
-target_link_libraries(wolff gsl m cblas fftw3 tcmalloc profiler)
-#target_link_libraries(pt_wolff gsl m jst cblas tcmalloc profiler)
+target_link_libraries(wolff_potts gsl m cblas fftw3)
+target_link_libraries(wolff_vector gsl m cblas fftw3)
-install(TARGETS wolff DESTINATION bin)
+install(TARGETS wolff_potts wolff_vector DESTINATION bin)