summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2018-07-23 13:51:13 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2018-07-23 13:51:13 -0400
commit639552a2649139ba14363f30daa20786532b21b0 (patch)
tree624ef3537222183d5474d3a2d05a8bf09611d330 /CMakeLists.txt
parentdd2c47db3512658858685c83dd772603203aaab1 (diff)
downloadc++-639552a2649139ba14363f30daa20786532b21b0.tar.gz
c++-639552a2649139ba14363f30daa20786532b21b0.tar.bz2
c++-639552a2649139ba14363f30daa20786532b21b0.zip
implemented the discrete gaussian model for roughening
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5269c48..84c8fb3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,12 +16,15 @@ file(GLOB CPPSOURCES lib/*.cpp)
add_executable(wolff_finite src/wolff_finite.c ${CSOURCES})
add_executable(wolff_ising src/wolff_ising.cpp ${CPPSOURCES} ${CSOURCES})
+add_executable(wolff_dgm src/wolff_dgm.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_3potts src/wolff_potts.cpp ${CPPSOURCES} ${CSOURCES})
+add_executable(wolff_4potts src/wolff_potts.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_planar src/wolff_On.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_heisenberg src/wolff_On.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(analyze_correlations src/analyze_correlations.cpp ${CPPSOURCES} ${CSOURCES})
SET_TARGET_PROPERTIES(wolff_3potts PROPERTIES COMPILE_FLAGS "-DPOTTSQ=3")
+SET_TARGET_PROPERTIES(wolff_4potts PROPERTIES COMPILE_FLAGS "-DPOTTSQ=4")
SET_TARGET_PROPERTIES(wolff_planar PROPERTIES COMPILE_FLAGS "-DN_COMP=2")
SET_TARGET_PROPERTIES(wolff_heisenberg PROPERTIES COMPILE_FLAGS "-DN_COMP=3")
@@ -37,19 +40,24 @@ target_link_libraries(wolff_finite cblas gsl m)
target_link_libraries(analyze_correlations cblas gsl fftw3 m)
if (${GLUT} MATCHES "GLUT-NOTFOUND")
target_link_libraries(wolff_ising cblas gsl m)
+ target_link_libraries(wolff_dgm cblas gsl m)
target_link_libraries(wolff_3potts cblas gsl m)
target_link_libraries(wolff_heisenberg cblas gsl m)
target_link_libraries(wolff_planar cblas gsl m)
else()
target_link_libraries(wolff_ising cblas gsl m glut GL GLU)
+ target_link_libraries(wolff_dgm cblas gsl m glut GL GLU)
target_link_libraries(wolff_3potts cblas gsl m glut GL GLU)
+ target_link_libraries(wolff_4potts cblas gsl m glut GL GLU)
target_link_libraries(wolff_heisenberg cblas gsl m glut GL GLU)
target_link_libraries(wolff_planar cblas gsl m glut GL GLU)
target_compile_definitions(wolff_ising PUBLIC HAVE_GLUT)
+ target_compile_definitions(wolff_dgm PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_3potts PUBLIC HAVE_GLUT)
+ target_compile_definitions(wolff_4potts PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_planar PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_heisenberg PUBLIC HAVE_GLUT)
endif()
-install(TARGETS wolff_finite wolff_ising wolff_3potts wolff_heisenberg wolff_planar analyze_correlations DESTINATION bin)
+install(TARGETS wolff_finite wolff_ising wolff_dgm wolff_3potts wolff_heisenberg wolff_planar analyze_correlations DESTINATION bin)