summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2020-04-16 07:53:05 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2020-04-16 07:53:05 -0400
commitc162d9db4fe030b327718f9e06a5f67f0fedcce0 (patch)
tree37951b32c5cba48bbc527cbc601be38a2d90c26f
parenteef74644a97911df2f68c0f2ca62a99a65398266 (diff)
downloadlinux-pinebook-c162d9db4fe030b327718f9e06a5f67f0fedcce0.tar.gz
linux-pinebook-c162d9db4fe030b327718f9e06a5f67f0fedcce0.tar.bz2
linux-pinebook-c162d9db4fe030b327718f9e06a5f67f0fedcce0.zip
Added loose install file.
-rw-r--r--PKGBUILD4
-rw-r--r--linux-pinebook.install27
2 files changed, 30 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8d5bc00..e445753 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,6 +24,7 @@ source=(
'kernel_data_key.vbprivk'
'linux.preset'
'99-linux.hook'
+ 'linux-pinebook.install'
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
@@ -37,7 +38,8 @@ md5sums=('SKIP'
'61c5ff73c136ed07a7aadbf58db3d96a'
'584777ae88bce2c5659960151b64c7d8'
'1bcc6c5d103b31523c5077b7c89f2b79'
- '1d4477026533efaa0358a40855d50a83')
+ '1d4477026533efaa0358a40855d50a83'
+ 'f651f0703afcc2ac86fbfec7eef74565')
prepare() {
cd "${srcdir}/${_srcname}"
diff --git a/linux-pinebook.install b/linux-pinebook.install
new file mode 100644
index 0000000..055c9a4
--- /dev/null
+++ b/linux-pinebook.install
@@ -0,0 +1,27 @@
+# arg 1: the new package version
+# arg 2: the old package version
+
+KERNEL_NAME=-pinebook
+KERNEL_VERSION=5.7.0-rc1-3-ARCH+
+
+post_install () {
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ depmod ${KERNEL_VERSION}
+}
+
+post_upgrade() {
+ if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
+ echo "WARNING: /boot appears to be a separate partition but is not mounted."
+ fi
+
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ depmod ${KERNEL_VERSION}
+}
+
+post_remove() {
+ # also remove the compat symlinks
+ rm -f boot/initramfs-linux.img
+ rm -f boot/initramfs-linux-fallback.img
+}