summaryrefslogtreecommitdiff
path: root/linux-pinebook.install
diff options
context:
space:
mode:
Diffstat (limited to 'linux-pinebook.install')
-rw-r--r--linux-pinebook.install27
1 files changed, 27 insertions, 0 deletions
diff --git a/linux-pinebook.install b/linux-pinebook.install
new file mode 100644
index 0000000..055c9a4
--- /dev/null
+++ b/linux-pinebook.install
@@ -0,0 +1,27 @@
+# arg 1: the new package version
+# arg 2: the old package version
+
+KERNEL_NAME=-pinebook
+KERNEL_VERSION=5.7.0-rc1-3-ARCH+
+
+post_install () {
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ depmod ${KERNEL_VERSION}
+}
+
+post_upgrade() {
+ if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
+ echo "WARNING: /boot appears to be a separate partition but is not mounted."
+ fi
+
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ depmod ${KERNEL_VERSION}
+}
+
+post_remove() {
+ # also remove the compat symlinks
+ rm -f boot/initramfs-linux.img
+ rm -f boot/initramfs-linux-fallback.img
+}