summaryrefslogtreecommitdiff
path: root/linux-pinebook.install
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2020-04-16 07:53:05 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2020-04-16 07:53:05 -0400
commitc162d9db4fe030b327718f9e06a5f67f0fedcce0 (patch)
tree37951b32c5cba48bbc527cbc601be38a2d90c26f /linux-pinebook.install
parenteef74644a97911df2f68c0f2ca62a99a65398266 (diff)
downloadlinux-pinebook-c162d9db4fe030b327718f9e06a5f67f0fedcce0.tar.gz
linux-pinebook-c162d9db4fe030b327718f9e06a5f67f0fedcce0.tar.bz2
linux-pinebook-c162d9db4fe030b327718f9e06a5f67f0fedcce0.zip
Added loose install file.
Diffstat (limited to 'linux-pinebook.install')
-rw-r--r--linux-pinebook.install27
1 files changed, 27 insertions, 0 deletions
diff --git a/linux-pinebook.install b/linux-pinebook.install
new file mode 100644
index 0000000..055c9a4
--- /dev/null
+++ b/linux-pinebook.install
@@ -0,0 +1,27 @@
+# arg 1: the new package version
+# arg 2: the old package version
+
+KERNEL_NAME=-pinebook
+KERNEL_VERSION=5.7.0-rc1-3-ARCH+
+
+post_install () {
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ depmod ${KERNEL_VERSION}
+}
+
+post_upgrade() {
+ if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
+ echo "WARNING: /boot appears to be a separate partition but is not mounted."
+ fi
+
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ depmod ${KERNEL_VERSION}
+}
+
+post_remove() {
+ # also remove the compat symlinks
+ rm -f boot/initramfs-linux.img
+ rm -f boot/initramfs-linux-fallback.img
+}