summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 11 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a5a77c..db7d193 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,9 @@
# Contributor: Kevin Mihelich <kevin@archlinuxarm.org>
pkgname=uboot-pinebook
-pkgver=v2019.01.rc3.r35.g64abfc9b6b
-pkgrel=2
+pkgver=2020.04
+pkgrel=1
+_tfaver=2.3
pkgdesc="U-Boot for Pine64"
arch=('aarch64')
url='http://www.denx.de/wiki/U-Boot/WebHome'
@@ -12,36 +13,22 @@ license=('GPL')
makedepends=('bc' 'git' 'python' 'swig' 'dtc')
backup=('boot/extlinux/extlinux.conf')
install=${pkgname}.install
-source=('git+https://github.com/u-boot/u-boot.git#commit=64abfc9b6bb3'
- 'git+https://github.com/ARM-software/arm-trusted-firmware.git#commit=63b9b5425f15'
- '0001-ATF-set-fno-stack-protector.patch'
+source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
+ "https://git.trustedfirmware.org/TF-A/trusted-firmware-a.git/snapshot/trusted-firmware-a-$_tfaver.tar.gz"
'extlinux.conf')
-md5sums=('SKIP'
- 'SKIP'
- '3213c96ce0713249719dc73d58395620'
+md5sums=('51113d2288c55110e33a895c65ab9f60'
+ '628a32a3c3b3f0c567d1ea6ee5582807'
'96aebf8a7cca044bb2c765ba8812299b')
-pkgver() {
- cd u-boot
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd u-boot
-
- cd ../arm-trusted-firmware
- git apply ../0001-ATF-set-fno-stack-protector.patch
-}
-
build() {
unset CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
- cd arm-trusted-firmware
+ cd trusted-firmware-a-$_tfaver
make PLAT=sun50i_a64 DEBUG=1 bl31
- cp build/sun50i_a64/debug/bl31.bin ../u-boot
+ cp build/sun50i_a64/debug/bl31.bin ../u-boot-${pkgver/rc/-rc}
- cd ../u-boot
+ cd ../u-boot-${pkgver/rc/-rc}
make distclean
make pinebook_defconfig
@@ -51,7 +38,7 @@ build() {
}
package() {
- cd u-boot
+ cd u-boot-${pkgver/rc/-rc}
mkdir -p "${pkgdir}"/boot/extlinux