summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJaron Kent-Dobias <jaron@kent-dobias.com>2018-07-26 16:55:17 -0400
committerJaron Kent-Dobias <jaron@kent-dobias.com>2018-07-26 16:55:17 -0400
commit5f1eb9a12821e7462b7b2853e0d95c8c863bf900 (patch)
tree6aa091a95846923e253a83886c5da2a8a62d5e93 /CMakeLists.txt
parent1160baa61bad605cf8a1d583e8ae356a54a942df (diff)
downloadc++-5f1eb9a12821e7462b7b2853e0d95c8c863bf900.tar.gz
c++-5f1eb9a12821e7462b7b2853e0d95c8c863bf900.tar.bz2
c++-5f1eb9a12821e7462b7b2853e0d95c8c863bf900.zip
now using const passing of object reference instead of pointers
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 12fe087..fe564f7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,7 +22,6 @@ add_executable(wolff_4potts src/wolff_potts.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_7potts src/wolff_potts.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_3clock src/wolff_clock.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_5clock src/wolff_clock.cpp ${CPPSOURCES} ${CSOURCES})
-add_executable(wolff_planar2 src/wolff_O2.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_planar src/wolff_On.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(wolff_heisenberg src/wolff_On.cpp ${CPPSOURCES} ${CSOURCES})
add_executable(analyze_correlations src/analyze_correlations.cpp ${CPPSOURCES} ${CSOURCES})
@@ -55,7 +54,6 @@ if (${GLUT} MATCHES "GLUT-NOTFOUND")
target_link_libraries(wolff_5clock cblas gsl m)
target_link_libraries(wolff_heisenberg cblas gsl m)
target_link_libraries(wolff_planar cblas gsl m)
- target_link_libraries(wolff_planar2 cblas gsl m)
else()
target_link_libraries(wolff_ising cblas gsl m glut GL GLU)
target_link_libraries(wolff_dgm cblas gsl m glut GL GLU)
@@ -67,7 +65,6 @@ else()
target_link_libraries(wolff_5clock cblas gsl m glut GL GLU)
target_link_libraries(wolff_heisenberg cblas gsl m glut GL GLU)
target_link_libraries(wolff_planar cblas gsl m glut GL GLU)
- target_link_libraries(wolff_planar2 cblas gsl m glut GL GLU)
target_compile_definitions(wolff_ising PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_dgm PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_cgm PUBLIC HAVE_GLUT)
@@ -77,7 +74,6 @@ else()
target_compile_definitions(wolff_3clock PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_5clock PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_planar PUBLIC HAVE_GLUT)
- target_compile_definitions(wolff_planar2 PUBLIC HAVE_GLUT)
target_compile_definitions(wolff_heisenberg PUBLIC HAVE_GLUT)
endif()