summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Johansen <strit@manjaro.org>2020-05-21 22:39:53 +0200
committerDan Johansen <strit@manjaro.org>2020-05-21 22:39:53 +0200
commit57e9a4c5599e47d0681a9602142fe081abfcef02 (patch)
treef2eaf9f5106dd0c328a709a62366ca8ea4a4567d
parentb3ba8331d7a741eee5b34324b1b3a800946d1dbf (diff)
downloaduboot-pinebook-57e9a4c5599e47d0681a9602142fe081abfcef02.tar.gz
uboot-pinebook-57e9a4c5599e47d0681a9602142fe081abfcef02.tar.bz2
uboot-pinebook-57e9a4c5599e47d0681a9602142fe081abfcef02.zip
update to 2020.04
-rw-r--r--0001-ATF-set-fno-stack-protector.patch26
-rw-r--r--PKGBUILD35
2 files changed, 11 insertions, 50 deletions
diff --git a/0001-ATF-set-fno-stack-protector.patch b/0001-ATF-set-fno-stack-protector.patch
deleted file mode 100644
index 47721b4..0000000
--- a/0001-ATF-set-fno-stack-protector.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 45018dbfb301759c9debff598a509832e35854a9 Mon Sep 17 00:00:00 2001
-From: Kevin Mihelich <kevin@archlinuxarm.org>
-Date: Sat, 19 Aug 2017 15:28:38 -0600
-Subject: [PATCH] ATF: set -fno-stack-protector
-
----
- Makefile | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index 74d51804..0af9b350 100644
---- a/Makefile
-+++ b/Makefile
-@@ -202,7 +202,8 @@ ASFLAGS += $(CPPFLAGS) $(ASFLAGS_$(ARCH)) \
- -Wa,--fatal-warnings
- TF_CFLAGS += $(CPPFLAGS) $(TF_CFLAGS_$(ARCH)) \
- -ffreestanding -fno-builtin -Wall -std=gnu99 \
-- -Os -ffunction-sections -fdata-sections
-+ -Os -ffunction-sections -fdata-sections \
-+ -fno-stack-protector
-
- GCC_V_OUTPUT := $(shell $(CC) -v 2>&1)
-
---
-2.19.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 8a5a77c..db7d193 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,9 @@
# Contributor: Kevin Mihelich <kevin@archlinuxarm.org>
pkgname=uboot-pinebook
-pkgver=v2019.01.rc3.r35.g64abfc9b6b
-pkgrel=2
+pkgver=2020.04
+pkgrel=1
+_tfaver=2.3
pkgdesc="U-Boot for Pine64"
arch=('aarch64')
url='http://www.denx.de/wiki/U-Boot/WebHome'
@@ -12,36 +13,22 @@ license=('GPL')
makedepends=('bc' 'git' 'python' 'swig' 'dtc')
backup=('boot/extlinux/extlinux.conf')
install=${pkgname}.install
-source=('git+https://github.com/u-boot/u-boot.git#commit=64abfc9b6bb3'
- 'git+https://github.com/ARM-software/arm-trusted-firmware.git#commit=63b9b5425f15'
- '0001-ATF-set-fno-stack-protector.patch'
+source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
+ "https://git.trustedfirmware.org/TF-A/trusted-firmware-a.git/snapshot/trusted-firmware-a-$_tfaver.tar.gz"
'extlinux.conf')
-md5sums=('SKIP'
- 'SKIP'
- '3213c96ce0713249719dc73d58395620'
+md5sums=('51113d2288c55110e33a895c65ab9f60'
+ '628a32a3c3b3f0c567d1ea6ee5582807'
'96aebf8a7cca044bb2c765ba8812299b')
-pkgver() {
- cd u-boot
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd u-boot
-
- cd ../arm-trusted-firmware
- git apply ../0001-ATF-set-fno-stack-protector.patch
-}
-
build() {
unset CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
- cd arm-trusted-firmware
+ cd trusted-firmware-a-$_tfaver
make PLAT=sun50i_a64 DEBUG=1 bl31
- cp build/sun50i_a64/debug/bl31.bin ../u-boot
+ cp build/sun50i_a64/debug/bl31.bin ../u-boot-${pkgver/rc/-rc}
- cd ../u-boot
+ cd ../u-boot-${pkgver/rc/-rc}
make distclean
make pinebook_defconfig
@@ -51,7 +38,7 @@ build() {
}
package() {
- cd u-boot
+ cd u-boot-${pkgver/rc/-rc}
mkdir -p "${pkgdir}"/boot/extlinux